« お二方からビールウェア。 | トップページ | 超微速。 »

2012年12月13日 (木)

Umbra は factor。

いつも言っていることですんで、いまさらですけど、


パラメータの UI 上の名前と内部的な名前は統一して下さい。
せめて類推できるくらい近しい名前にして下さい。


オーバーライドする時いちいち探すのが面倒なんですよ。


オーバーライドする前にそのパラメータいじってみて、ログを見れば内部的な名前はすぐわかりますけどね。でも、いざこれからオーバーライドするぜって時は、気持ちとしてそういうことをする方向には向かないですよね。おら~オーバーライドするぜ~って気分になってますから、いきなりオーバーライド与えてパラメータ追加しようとするじゃないですか。 そのときに、あれ? 見つからないぞ? このパラメータ、なんて名前だ? と毎回右往左往するんです。そうなんです。 今日はこれでした。


Umbra

Umbra が factor ですか。
そうなんですか。
死んで下さい。



全部 Umbra でいいじゃないか。 「カゲの部分」とかそういう意味の英語でしょ。 なぜ内部は factor なんていう違う名前使うんですか。 factor っていうと、係数とかそういうニュアンスですか。 そうなると、内部計算的に、シャドウ部分のピクセルの輝度に掛け合わせる値だとかそういう感じなんですかね? 違いますかね?  もしそうだとしたら、factor ってのは内部アルゴリズムに着目した名前の付け方ですよね。開発者にとってはピンと来る名前なのかもしれませんが、ユーザにとってはそんなの超不親切ですよね。


アルゴリズム的なものをパラメータ名として表に出して分かりにくくなるのは、なんとなくメンタル霊のお家芸のような気がするんですがどうですか。 パラメータの名前を見ても、いったい何を変えるためのパラメータなのか想像がつかない、みたいな、いつもそんな印象がありますよ俺は。 BA とか Holger さんのシェーダもそうだよな。 

で、ある他のパラメータがある程度以上の値になってないとそのパラメータいじっても変化がわからないとか。 あと、0.0005 みたいな値が続出するとか。小数点以下どんだけゼロ付けなきゃならんのですか。 かと思うと 100,000,000 みたいな値もあるしなあ。 アルゴリズム丸出しじゃなくて、それを分かりやすくラッピングして上手く UI にまとめるだとか、別PPG を作って連動していじれるようにするだとか、そういう分かりやすい設計というのがヘタなんではなかろうか。メンタル霊さん。 あるいは嘔吐デスクさまか?


今回の場合は逆かな。 UI の名前は分かり易いが、内部的にはアルゴリズムを表したかのような名前になってるので、オーバーライドの時に困るという。 オーバーライドも UI 名で出来ればそれでもいいんだけどな。



とかなんとか。

ソフトウェアはわかりやすく作って下さい嘔吐デスクさま。





.

|

« お二方からビールウェア。 | トップページ | 超微速。 »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック


この記事へのトラックバック一覧です: Umbra は factor。:

« お二方からビールウェア。 | トップページ | 超微速。 »